La versione 9.70 del PICC Compiler va in crash?

Alcuni utenti, sia qui su settorezero.com che sul forum della Microchip stanno lamentando che l’ultima versione del PICC compiler al momento in cui scrivo (la 9.70 sia in versione LITE, che in versione PRO demo, che in versione PRO con tanto di licenza acquistata) vada in crash compilando alcuni programmi che non presentano errori e che venivano compilati correttamente con la versione precedente (la 9.65PL1).

La discussione  sul forum della Microchip è raggiungibile qui:

http://www.microchip.com/forums/tm.aspx?m=470337

Riguardo al nostro corso di programmazione, sembra che l’unico programma che mandi in errore il PICC compiler 9.70 è quello relativo all’esempio sulla RS232, nella fattispecie il programma non viene compilato e si presenta una finestra di errore che recita “cgpic.exe ha causato errori e sarà terminato”.

Ovvio che si tratta di un bug del compilatore e non di un errore del programma che proviamo a compilare, altrimenti ci sarebbe stata una classica stringa di errore nella finestra del compilatore.

Leggendo nel forum di supporto, in molti stanno avendo questo problema e la Microchip nel frattempo pare abbia rilasciato una nuova release candidate che però non è possibile scaricare (probabilmente è stata resa disponibile solo agli acquirenti delle licenze mentre il problema viene risolto).

Nel frattempo che gli addetti risolvono il bug, se avete problemi potete installare la versione 8.40 di MPLAB IDE che è l’ultima ad avere l’Hitec-C versione 9.65PL1. E’ possibile scaricarla dalla pagina di archivio della Microchip all’indirizzo:

http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en023073

Se questo articolo ti è piaciuto, condividilo su un social:
  •  
  •  
  •  
  •  
  •  
  •  
Se l'articolo ti è piaciuto o ti è stato utile, potresti dedicare un minuto a leggere questa pagina, dove ho elencato alcune cose che potrebbero farmi contento? Grazie :)